What we collect!
Stamporama Discussion Board Logo
For People Who Love To Talk About Stamps


62 visitors online

Club Business & Announcements/Tech Advice : Why don't certain unicode characters work here?

AuthorPostings
Ningpo
Members Picture

28 Oct 2015
04:05:19pm
I've noticed that a few unicode characters don't work on this site. I have found four so far, that when entered, either jump back to the 'Start new thread' screen, or throw me out of the site completely.

I've tested these elsewhere with no problems. The codes in question are:

Unicode: 0214 - Capital 'O' with umlaut

Unicode: 0224 - lower case 'a' with grave accent

Unicode: 0246 - lower case 'o' with umlaut

Unicode: 0241 - lower case 'n' with tilda (the wiggly worm on the top)

Can anyone suggest an alternative character code set?

Like
Login to Like
this post
BobbyBarnhart
Members Picture

They who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. -Benjamin Franklin
28 Oct 2015
04:50:02pm
re: Why don't certain unicode characters work here?

You mean stuff like: Ö à ö â ñ Ñ Ü ü æ ą Ł œ?

Wish I knew an easy way, but when I want to use them I have to copy them individually from my word processor.


Like
Login to Like
this post

"The only thing necessary for the triumph of evil is for good men to do nothing. -Edmund Burke"

www.bobbybarnhart.net
Ningpo
Members Picture

28 Oct 2015
05:01:38pm
re: Why don't certain unicode characters work here?

Yes those ones. I have printed a Unicode list off and use this most of the time. Although the list is not comprehensive, most of the more common characters work fine. The four that I've tried and there may be others, just go loopy.

I can enter these onto sticky notes (Windows 7 Pro) with no problem. Microsoft Word works differently in that you 'insert character' from a table, which includes Unicode characters.

Perhaps I'll stick with the sticky, it might be less tricky.

Like
Login to Like
this post
roy
Members Picture

BuckaCover.com - 80,000 covers priced 60c to $1.50 - Easy browsing 300 categories
28 Oct 2015
05:02:56pm
re: Why don't certain unicode characters work here?

Ö à ö ñ

They all work fine for me. Hold down the Alt key and type in the number.

If they aren't working for you, it's probably a browser issue, rather than a server issue. I am using Google Chrome.

Roy

Like
Login to Like
this post

"BuckaCover.com - 80,000 covers priced 60c to $1.50- 7,500 new covers coming Thursday Sept. 16"

www.Buckacover.com
Ningpo
Members Picture

28 Oct 2015
05:06:33pm
re: Why don't certain unicode characters work here?

That's just what I have been doing Roy. I have Google Chrome too.

Curiouser and curiouser!

Like
Login to Like
this post
Ningpo
Members Picture

28 Oct 2015
05:17:50pm
re: Why don't certain unicode characters work here?

Image Not Found

Like
Login to Like
this post
roy
Members Picture

BuckaCover.com - 80,000 covers priced 60c to $1.50 - Easy browsing 300 categories
28 Oct 2015
05:26:27pm
re: Why don't certain unicode characters work here?

If I were troubleshooting this, two possibilities occur to me for investigation. (I am not saying either of these are the issue, just suggesting lines of investigation).

#1) Font incompatibility. I note the font in your sticky notes is "unique".

#2) language setting differences. You are in the UK, so you are not likely to be set up with Windows and keyboard languages as "English (USA)", which I am.

Roy

Like
Login to Like
this post

"BuckaCover.com - 80,000 covers priced 60c to $1.50- 7,500 new covers coming Thursday Sept. 16"

www.Buckacover.com
Ningpo
Members Picture

28 Oct 2015
05:37:21pm
re: Why don't certain unicode characters work here?

Thanks for those suggestions. I am not aware of any way to set the sticky notes font but yes, it does look a little odd. I guess it's trying to replicate a handwriting style.

I'll check out my keyboard setting.

Like
Login to Like
this post
nigelc
Members Picture

28 Oct 2015
07:22:11pm
re: Why don't certain unicode characters work here?


I believe in the past this discussion board didn't support Unicode - I'm delighted to see it does now.

e.g. Добро пожаловать в Википедию (from the Russian Wikipedia home page).



Like
Login to Like
this post
TuskenRaider
Members Picture

29 Oct 2015
01:15:20am
re: Why don't certain unicode characters work here?

Hi Everyone;

Unicode is not supported by all browsers and operating systems, but this will work.

I've experimented with this problem in my listings. I use these codes for listings:

XHTML Character Entity Reference

They are called Extended Hypertext Mark up Language (XHTML) Character Entity References.

They all begin with '&' and end with ';', and the stuff in between tell the browsers what to display. There are about 250+ of them on the above linked site.

for example:
& + O + uml + ; = Ö

some more:

frac12 = ½
frac14 = ¼
frac34 = ¾
pound = £
cent = ¢
euro = €
yen = ¥
agrave = à
ouml = ö
ntilde = ñ


As far as I know they will work anywhere on the web.

In my experiments with listings I did discover an anomaly in the text used in the title.
A few of these won't work. In addition the characters " and : will terminate the title
and any text after those characters disappear.

Just sortin'....
TuskenRaider

Like
Login to Like
this post

www.webstore.com/store,pgr,37572,user_id,37572,ac,shop
Ningpo
Members Picture

29 Oct 2015
07:10:51am
re: Why don't certain unicode characters work here?

Thank you for that info. Which font is used for posts?

Like
Login to Like
this post
TuskenRaider
Members Picture

29 Oct 2015
09:03:04am
re: Why don't certain unicode characters work here?

Hi Ningpo;

I think it doesn't matter, because if you look and the window that you type a message into, it is a mono-spaced font similar to Courier. But after you hit "preview" or "submit message", it defaults to whatever the system default font is.

The auctions are maybe different, because they allow HTML in the body of the description. However making auctions is enough work as it is, and so I decline to play with something just because I can. I have used a decorative font to label some of my images, with my item numbers, but they are generated in a paint program and are bitmaps.

I use these characters extensively in the auction description body text to make it more readable. So just use this format (& + O + uml + ; = Ö), without the +s, and it should work correctly. I've been using these codes on a number of auction sites successfully for several years. A girl from eBid's forum, who lives in England was the person who told me about them.

Well gotta get back to sorting, several of my buyers are anxious for newer material.

Just sortin'....
TuskenRaider

Like
Login to Like
this post

www.webstore.com/store,pgr,37572,user_id,37572,ac,shop
BobbyBarnhart
Members Picture

They who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety. -Benjamin Franklin
29 Oct 2015
09:18:07am
re: Why don't certain unicode characters work here?

Thanks, Ken. I had that page bookmarked once, then lost track of it. It is a very useful reference. For those of you who have difficulty in getting "links" to work, there is also "percent encoding" references on THIS PAGE (the most commonly used of which is the substitution of "%2c" for commas in URLs (more correctly URIs)).

Like
Login to Like
this post

"The only thing necessary for the triumph of evil is for good men to do nothing. -Edmund Burke"

www.bobbybarnhart.net
Ningpo
Members Picture

29 Oct 2015
09:27:38am
re: Why don't certain unicode characters work here?

Thank you TuskenRaider. It works very well and is quite intuitive for many symbols.

Ñ
ö
à
Ö
±
°

¼
½
¾

Like
Login to Like
this post
        
Please Note:
Postings that were loaded from the old Discussion Board cannot be edited.

Contact Webmaster | Visitors Online | Unsubscribe Emails


User Agreement

Copyright © 2021 Stamporama.com